dotfiles.nix/systems/darwin/work.nix

21 lines
460 B
Nix

{ lib, ... }:
{
homebrew.casks = [
"itsycal"
"pallotron-yubiswitch"
];
home-manager.sharedModules = [
{
launchd.agents.tarsnap.enable = lib.mkForce false;
programs.ssh.matchBlocks.devbox = {
hostname = "csdev6";
forwardAgent = true;
serverAliveInterval = 120;
};
programs.fish.functions.devbox.body = ''
ssh -t devbox "agenttmux attach; or agenttmux new -s yelp"
'';
}
];
}